Powershell universal ssh commands

Hi,
Im trying to run sshcommand from Universal install on windows 10 , with posh-ssh module install, I get error, also I try different ssh module sshsessions I get error.

I currently can’t shares the error, it sad can’t login to…
If I try from ise it’s work

Please advice
Itamar

Without the error message it’s unlikely we’ll be able to help much. If you want to email support to keep it off the public forum, feel free.

Hi , I imported the posh-ssh module, tried to create an ssh connection to remote switch and got this error:

Could not liad type ‘System.Security. Cryptography. HMACRIPEMD160’ from assembly ‘mscorlib, version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’

After looking it up I tried adding attribute -UseWindowsPowershell when importing the module and then got this error while trying to connect:

Switc: Error was Exception calling “GetSteppablePipeline” with “1” argument(s): "The parameter is incorrect. " at line: 4500

Hi, I also tried to import DataONTAP module that succeeded to import but Connect-NcController still doesn’t work. I get the same error:
Error was Exception calling “GetSteppablePipeline” with “1” argument(s): "The parameter is incorrect. "

It sounds like these modules are only supported in Windows PowerShell. Try to change the environment you are running the script in from Default (Integrated) to v5

Hi,
We try this , and also supply module=*
Its not working.

Please advise
Itamar

When you run as v5, do you get the same error?

Yes, I don’t have 7 on my computer.

Br,

Itamar

Ok. I’ll open an issue for this and try that module myself. I have no idea why it wouldn’t work in a v5 environment.

Hi ,
Any suggestions regards this issue?
We sean this on a different models like netapp.
It’s look like ps universal can’t use modules that install on the same box.

Please advise
Itamar

I have tried the Posh-SSH module locally and have no problem loading that into PSU in any environment.

My script is just creating a new SSH session into a raspberry pi.

new-sshsession -ComputerName raspberrypi -Credential $pi

The credential is stored as a PSU variable.

It seems like there is something else happening in your environment. Are you running as a windows service? What version of PSU are you running?

Version 2.3.2 if I remember correctly.

Let me give that version a shot. I just tried in the latest.