New-UDButton -Icon wont show the selected icon image on the button

with new 2.4.0 release when using New-UDButton -Icon and select any icon from the list it wont show on the button after starting the dashboard.

Sounds like a bug. Can you please open a GitHub issue for it?

i just did open an issue on github, thanks adam

1 Like

@adam i have tried your Fix for this issue but the problem now is it only works locally and the issue still the same from IIS . No icons appeared when running the dashboard from IIS

I cannot get any money icons to work, and only the default truck image, no other truck images work…

I have no issue in IIS with this fix.

Ok. Will have to take a look. Likely a separate issue. Please open one on GitHub with the icons that are not working.

no worries @adam as there is so many icons to choose from I have used other icons. Will start to make a list of icons that I have issues wth then will raise a github request. Thanks

@adam what i did is i have downloaded the github version and run the build.ps1 -Configuration Release,
after its completed i did copy the content of index.37adbcd71105dc38ca2a.bundle & and the button script to preserve my original files names from 2.4.0

doing a test on multiple machines locally the icons shows up but from IIS none of the icons shows up on the button.
fyi am using community edition.

An Update:

it works when i change iis port from 80 to 1000

It’s probably a browser caching issue. Since you didn’t change the JS file names, the browser probably just loaded them from cache. If you try and do a Ctrl+F5, it should reload the JS from the server and not from the cache.

same issue , i have tried cache cleanup and stuff on multiple servers and still the same.

Update : changing file names works on port 80 now. Issue resolved