Multiple issues with PS Tools Pro on Visual Studio 2017

Just installed licensed version on VS2017 and having a number of issues.
Opening previous scripts written in Window PS hangs VS2017.
Wanted to try PS7 so changed it in the options menu but running a one line script with $PSVersionTable produced no errors and no output.
Even running commands from the interactive console simply returns the prompt with no output.

Grabbed the logs but not sure how to attach them here. I do see a number of warning messages such as:
[79] WARN PowerShellTools.Classification.PowerShellTokenizationService (null) - Failed to update task list!
System.InvalidOperationException: Due to high risk of deadlock you cannot call GetService from a background thread in an AsyncPackage derived class.

Can you DM me the logs and use something like Firefox Send?

Tried to send Firefox link but got this error:


Sorry, new users can only put one image in a post.

If you can correct the problem, please try again.


Please try this link:


Thanks. That worked. I’ll let you know what I find.

Any updates on this issue?
VS2017 seems to hang a lot just trying to open a project created with this PS Tools.

Sorry. I totally dropped the ball on this. Can you email me at It will be easier for me to prioritize that way. It might be nice to setup a Zoom call to look at this together as I’m not seeing the same issue.