Locked out of PSU

Product: PowerShell Universal
Version: 4.1.7

I’m locked out after upgrading to 4.1.7, and I’ve tried clearing my browser cache, restarting the service and server, etc. After scanning the forums, I see this was an issue with some in the past. I even tried the 4.1.8 update.


You should be able to reset the admin login

Alternativly, edit Roles.ps1 and let Administrator return $true always

No change

script ran for about 3 hours. Looks like it might have been caught in a loop. I killed it and restarted the services. Now the site won’t load.

You will need to look in Event Viewer \ Application log if the service is not starting. It’s likely due to some sort of unhandled exception.

The other place you will need to look is in %ProgramData%\PowerShellUniversal system logs. Search for the latest [ERR] messages.

2023-11-01 13:07:00.154 -04:00 [ERR] Startup: The term ‘Use’ is not recognized as a name of a cmdlet, function, script file, or executable program.
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
2023-11-01 13:07:00.154 -04:00 [ERR] Startup: at , C:\ProgramData\UniversalAutomation\Repository\dashboards\Alonzo\Alonzo.ps1: line 7
at , : line 1

I renamed the extension for the file in the error, restarted services and am getting the same error in the log and still locked out.

I think I would need the whole log to understand what is happening here. It seems like more than just the admin password\role is messed up.

Can you send the log and the repository directory to support[at]iromansoftware.com?

I was able to login to the server with another account that has admin rights to PSU. I deleted my normal account and recreated it. Now I’m able to login normally,