LiteDB and Logging issues - Azure Container Web App

Hi @adam,

as I was using PSU to a great success in my last job, I am trying to build a PoC PSU instance in my current job too. I need to do that in Azure.
I deployed a Web App for Containers as described here
Image: ironmansoftware/universal:latest

After the install I am getting errors:

/Data/log-log.db is not accessible, insufficient permissions

Nonetheless, I was able to configure identities, tokens, endpoints, scripts, schedules etc. But after a few hours I am unable to run any script, getting this error:

Error executing job: LiteDB ENSURE: transaction must be active to rollback (current state: Disposed)

Tried loading several docker images / versions (4.2.19, 4.2.20, 4.2.0LTSR …). Tried also removing all 4 DBs from Storage and having them recreated. Nothing helped.

Thanks for any guidance on this!
PS: a Windows docker image is not an option due to its price.
Maybe @insomniacc could help me too? Saw a few mentions of similar problems here but didn’t really find a solution.

Product: PowerShell Universal
Version: 4.2.21