Issue with scheduler


After 3.7.9 my installation went a bit sideways. After restoring issue with it sync and re-syncing all repo, I end up in weird situation, where scripts and API endpoints are operational, but scheduled tasks are not running.
I’ve tried to re-create them, set UTC at timezone, attempting to run manually, installing latest version of PSU, reinstalling PSU, nothing helped.
Hangfire - showing recuring jobs and actually it shows that they ran according to schedule. But no Jobs appear in PSU.

Product: PowerShell Universal
Version: 3.7.11

Clean DB didn’t solve problem as well.
Logs doesn’t show any errors at all.
Can anybody advice?

@adam - you are my only hope. I’m really desperate with this.
My schedules (all 30) are still not working and I do not understand how it can be fixed or what could cause such behavior.
I’ve done all I could. Updates, reboots, re-installs, new DB, excluded from GPO, investigation with Security on AV and IPS. No result at all. I’ve changed all components I could. The only thing that left - is VM re-install, but I’m locked with hundreds of local secret variables and external network rules. So it’ll take some time to move them to DB.

Can you at least advice what could cause such behavior or how to troubleshoot it? Manual script run, API’s are working, but only schedules are not creating jobs as they should.

Are you sure the scripts aren’t running at all? I wonder if for some reason the groom job is clearing out the jobs before you have time to see them. The fact that hangfire is running the jobs make me suspect that but just a shot in the dark.

You could just create a simple script on a schedule that writes out to a file or something to verify.

Are you using SQL for persistence or LiteDB?

Can you upload some screenshots of the hangfire dashboard? I’m interested in the jobs page and then any ExecutionService.Execute listings. Those are job executions. I’d also be curious in what your recurring jobs page looks like.

Feel free to open a support case for this ( and send some logs.

I have the same issue on 3.7.7, so is there a fix for this?

It was fixed in version 3.7.13.
Issue was related to incorrect job queue creation, when host has name with special characters.