Hidden table columns - 2.3.0

Product: PowerShell Universal
Version: 2.3.0

It would be fortuitous that you put this feature in to 2.3.0, as I had a use case for it. I tossed on 2.3.0 early tomorrow and started trying to work with this, but the columns are not hidden when marked. I thought this might be related to the issue with the initial release I saw Adam mention in another thread so I downloaded fresh 2.3.0 files this morning and same thing.

Oddity I noticed in VSCode when working with this, wasn’t sure if this might be a clue to the issue itself. The -Hidden parameter highlights blue

I’ll take a look. It should just work that way.

I just tried this with latest and it’s working for me. I used the example here:

$Data = try { get-service -ea Stop | select Name,@{n = "Status";e={ $_.Status.ToString()}},@{n = "StartupType";e={ $_.StartupType.ToString()}},@{n = "StartType";e={ $_.StartType.ToString()}} } catch {}
$Columns = @(
    New-UDTableColumn -Property Name -Title "Service Name" -IncludeInExport
    New-UDTableColumn -Property Status -Title Status 
    New-UDTableColumn -Property StartupType
    New-UDTableColumn -Property StartType -IncludeInExport -Hidden
New-UDTable -Id 'service_table' -Data $Data -Columns $Columns -Title 'Services' -ShowSearch -ShowPagination -Dense -Export

I pulled your example into a test dashboard and it looks to work fine. I don’t see how what i’ve written out is different than yours. Data source is the only thing that is differnt, mine comes from a sql query

Strange. Maybe there are some other options that are causing this to happen since you have a couple other things on. I’ll have to play with it.

Thought I would bring more info into this in hopes it might help Adam.

After working on this in my local dev i brought the same code into my production like lab environment to continue working out other stuff. I upgraded the lab to 2.3.1 to see how the -hidden would behave. And it worked!

The only real difference I can see in my code between these environments is that I’m running the page as a single dashboard within localdev, not even putting them within new-udpage. In my lab, the page is it’s own ps1 within new-udpage within a larger multi-page dashboard.

Weird. Ok. I can keep messing with it but I can’t reproduce this at the moment.

I’ll just hope that it working will follow me into production site :smiley: