Tool: PowerShell Module

In my previous post Package script for running in Linux - PowerShell Tools - Ironman Software Forums I stated I was able to create a linux executable for netapp31 and pwsh 7.0.3. When I run the executable in my development system it works perfectly, of course I have .Net and PWSH installed. I tried in a Linux system that has none of that installed, and the first time it ran I got an error as shown in the screenshot below. Googling the error I found out the solution to be to add the DOTNET_SYSTEM_GLOBALIZATION_INVARIANT setting as 1 before the program execution.

I wonder if that variable can be included in the generation of the executable so it does not have to be explicitly added as in my case. I will have to call the executable from a bash script in order to include the required setting.

Please advise,

1 Like

According to c# - ICU Package installation Linux - Stack Overflow that error can be avoided by adding the following lines in the .csproj


Thanks for the research. I’ve opened an issue for this and the other issue you are having with the latest version: Packaging for Linux does not work · Issue #860 · ironmansoftware/issues · GitHub