Error when creating executable in Linux Centos 7

Tool: PowerShell Module
Version: 5.7.2

I am trying to compile a PS1 into executable in Linux. I installed .net core SDK 3.1 and PWSH 7.1.1. Every time I run merge-module I get the error:

Merge-Script: Unable to find the specified file.

See console output below.

What am I doing wrong?

Please advise.

There were some issues with this running on Linux. I just fixed and validated them. I’ll release a new version shortly.

I just installed 5.7.3 and it is now compiling and running as expected in Linux, not in MacOS (see below). Thanks.

Adam, I have the same problem now in MacOS with the latest version 5.7.3. The error is similar to the one in Linux with 5.7.2. See below

I suppose the RuntimeIdentifier is “macos-x64” because I could not find any information about.


Please advise.

We don’t support Mac OS X compiling at the moment but I should be able to tweak it to get it to work. I’ll get that resolved and validated this week.

This was a pretty easy tweak. I got it running on Mac OSX: Packaging on Mac OSX - PowerShell Pro Tools

Thanks Adam, I tried already and worked perfectly in MacOS. It was a bit slow the first time it ran, but I supposed it was because of the initial compilation.