Automatic login use loginprovider?

Hey all,
So I have setup ADFS login, but the login dont automatic send the user to the ADFS, they need to click on the button.

How do it just automatic login with the only provider configured?

Hi @McAndersDK
Happy cake day!
-passthru on the auth method i believe.

Atleast it works on Azure / oauth authentication.

hmm that parameter need to be renamed :slight_smile:
but thanks for pointing it out :slight_smile:

1 Like

'tis fancy name bruv.

Nah, put an enhancement request on github bro, to open up a discussion regarding this.

Did it actually work? :slight_smile:

yeah it did :slight_smile:
well maybe I will :stuck_out_tongue: it’s a abuse of wellknown parameter (and one that come from the cmdletbinding). the function of it now, is not what we expect it to do :slight_smile:

1 Like

I see your point, -passthru is well established.
It’s descriptive yet misleading at the same time in this implementation :sweat_smile:
Github it bro! :slight_smile:

Do you know what happens if 2 providers are added? :slight_smile:

We clearly need some better documentation on this, or I need some better search abillity :wink:
Help file is also outdated :slight_smile:

I’ve tried it, as a testingmethod for the new oAuth v2.0
From my perspective, without knowing how it is actually built, i believe the -passthru param forces said auth method unless anything else is explicitly specified .

IE: you can use -passthru on a ADFS with passthru, and a “signinkey” method for RESTAPI, but the non-passthru won’t be avaliable on the dashboard.

I haven’t actually gotten the passthru param to work in my dashboard, but i believe that is an issue regarding the

Do you have adminmode enabled ? I had that, and it will not start up before I removed that :slight_smile:

Really? Interesting bug…
Thanks bro, i’ll give that a go once i get my oauth up and running :slight_smile:
Has this bug been githubified?

Well, no :stuck_out_tongue:
It could be an error, because the AdminModeAuthorizationPolicy were not defined? :slight_smile:

Ill test this and get back to you. The admin mode auth policy works fine on non passthru :open_mouth:

Hmm not sure what the hell were wrong before, but I am now able to add the adminmode switch without it breaking. weird! sorry for the offtrack
but I guess it’s a valid test anyway :slight_smile:

1 Like