Wsfed - HTTP Error 500

Product: PowerShell Universal
Version: 1.5.10

I am testing the 1.5.10 version (upgrade from 1.5.3), but I am having some issues with Wsfed authentication.
It worked without any issues before, but now when I try to authentication I am met with a “HTTP Error 500” when navigating to “/auth/signin-wsfed”.

I have checked the IDP logs, and they are OK. In the PowerShell Unviversal logs i can see:

2021-02-08T17:42:13.4253449+01:00 0HM6CA1O8PC6L:00000004 [INF] Request starting HTTP/1.1 POST http://idpserver.net/auth/signin-wsfed application/x-www-form-urlencoded 6071 (ca22a1cb)
2021-02-08T17:42:13.4270784+01:00 0HM6CA1O8PC6L:00000004 [WRN] ‘".AspNetCore.Correlation.WsFederation.DGmePmrODplgRlKhj_viKm8NLenduq_lMAicTN9hL2A"’ cookie not found. (85986347)
2021-02-08T17:42:13.4271502+01:00 0HM6CA1OPC6L:00000004 [INF] Error from RemoteAuthentication: “Correlation failed.”. (37f74bc6)
2021-02-08T17:42:13.4282095+01:00 0HM6CA1OPC6L:00000004 [ERR] Connection id ““0HM6CA1OPC6L””, Request id "“0HM6CA1OPC6L:00000004"”: An unhandled exception was thrown by the application. (560e7d32)
System.Exception: An error was encountered while handling the remote login.
—> System.Exception: Correlation failed.
— End of inner exception stack trace —
at Microsoft.AspNetCore.Authentication.RemoteAuthenticationHandler1.HandleRequestAsync() at Microsoft.AspNetCore.Authentication.AuthenticationMiddleware.Invoke(HttpContext context) at Microsoft.AspNetCore.Server.IISIntegration.IISMiddleware.Invoke(HttpContext httpContext) at Microsoft.AspNetCore.Server.Kestrel.Core.Internal.Http.HttpProtocol.ProcessRequests[TContext](IHttpApplication1 application)

Anyone know what could be the issue here?

@alexsmid, I’m getting the same error but using Azure AD Open ID Connect. I just came across this in the change log for PU


Could also be impacting wsfed auth.
I went to 1.5.9 and it’s working for me.

I just tested it with 1.5.11, bu still same error and same errors in the log.

Anyone has any clue?

This is still not working, if someone is interesting in solving it.
I switched to ADFS - OIDC instead, can give a guide for it if someone is interested in setting it up for ADFS.

I opened an issue for this so we can take a look. Glad OIDC is working for you and sorry about the trouble with WS-Fed.

1 Like