Write-PSULog Not Working


I’m having trouble with Write-PSULog. When I run a script that uses this command with just the Message parameter it doesn’t seem to write anything to Platform>Logging. I’ve tried messing around with my Logging Targets, created multiple PowerShell ones, etc. - but I’m still unsure if I’m properly implementing it as the documentation isn’t very clear on start to finish. It also seems a bit outdated to the recent changes of Logging Target Settings.

Also, side note, it seems to keep defaulting the filtering to nothing for Level and just User (no System).

I did delete all logs just to clear it up for my tests and wondering if now it won’t display anything? I checked “%ProgramData%\PowerShellUniversal” for a log.txt file but there were only date-formatted log files.

Perhaps I am not configuring my Logging Targets correctly? Can someone help provide some guindace? I just want to be able to write logs to Logging from within my scripts.

Product: PowerShell Universal
Version: 4.2.14