Upgraded to 3.0.1 - All script outputs fail now

Product: PowerShell Universal
Version: 3.0.1

All my scripts now fail with the following if I run the script directly or in pages.

[error] Assembly with same name is already loaded 


[error] The term 'Out-PSUPipeline' is not recognized as a name of a cmdlet, function, script file, or executable program.

I tried to upgrade with the zip, when that didnt work, I installed the MSI files to a new dir and updated my IIS directory to point to the new dir. Same result. I made sure to install the web hosting .net 6 install as required.

This is the same issue (and workaround) described here: Dashboards are failing to start after upgrading to PSU 3.0.1 - #9 by Dods80

Ah so if im still using the older UniversalDashboard system then i would need to remove it or wait till 3.0.2?

Yeah. If you are using both on the same server you may need to wait. We should have a new build out within the next day or so since this bug is impacting a lot of people that have upgraded.

I was referring to the old universal dashboard system, i was able to remove the 2.9.2 module under powershell universal and reload, all is working again. Thanks.

1 Like