Unable to get https to work on PowerShell Universal


I can’t get https to work on PowerShell Universal.

I generated a certificate from an AD server like my old 2.9.0 dashboard and edited appsettings.json with the following values:

	"Kestrel": {
		"Endpoints": {
			"HTTP": {
				"Url": "http://*:80"
			"HTTPS": {
				"Url": "http://*:443",
				"Certificate": {
					"Subject": "CN=srv-dashboard.intranet.fr",
					"Store": "My",
					"Location": "LocalMachine",
					"AllowInvalid": "true"
		"RedirectToHttps": "true"

I also tried unsuccessfully with the Path parameter instead of populating the certificate store.

On the browser, always the same error: SSL_ERROR_RX_RECORD_TOO_LONG

In Event Logs> Windows> Application I have the following error:

Category: Universal.Server.Services.DashboardManager
EventId: 0

Dashboard proxy for dashboard 1 not found.

I am far from being an expert in certificates and site hosting. I’m having a hard time figuring out what is causing this error.

Thanks for your help

Product: PowerShell Universal
Version: 1.4.7

I don’t know what that error means but I do notice that you have HTTP instead of HTTPS here. Does that change anything when you switch it to HTTPS?

I am ashamed :blush:. I was too busy looking for the problem elsewhere.

After correcting this typo I can access through HTTPS but I get stuck after Azure authentication.
I see Universal Dashboard loading then redirect to Azure authentication, I authenticate myself then the page remains blank and do not return to the url of my dashboard.
On my server, I disabled the firewall and the antivirus as a precaution while testing, but it didn’t change anything.

However no problem with http://localhost/admin (with “RedirectToHttps”: “false”)

In Azure> App Registrations, I have correctly filled in the authentication urls.

In event logs, no error.

Here is my log file : https://fromsmash.com/xBfNv1hkyQ-ct