Tried the Git integration, not with any luck

The docs doesnt mention “Branch” so I didnt fill that out in the appsettings.
The result was me files being synced to a new branch called “Master”.

I deleted it the master branch, and pointed appsettings to the branch instead.

The sync doesn’t work, but the status page keeps updating with “Success” and a new timestamp

is there any way to reset it?

Product: PowerShell Universal
Version: 2.3.0

I’ve enhanced the docs for git sync: Git - PowerShell Universal

The trick is really to ensure that the local repository folder is completely empty when doing the first sync. The same is also true for the first time you sync from a local repo to a remote. The remote repo needs to be completely empty.

1 Like

Very nice thanks, works now. good work on updating the docs that fast btw.

Another question arises.
I created a dashboard, that was synced just fine everywhere, then deleted it from the admin page.
its gone from the admin page of course but the dashboard folder and files still reside inside the repository. is this expected behaviour? can I just delete the file from the repo manually?

That’s currently expected behavior. The same holds true for scripts. You can just delete the file from the repo manually if you want it gone.

1 Like