Git Synchronization branch issues

Hi, I have an issue with the following, I’m trying to set the git branch to main but every time it syncs to the repo, it syncs to the master branch instead no matter what we do.

My settings file looks like this:

 "Data": {
"RepositoryPath": "%ProgramData%\\UniversalAutomation\\Repository",
"ConnectionString": "%ProgramData%\\UniversalAutomation\\database.db",
"DatabaseType": "LiteDB",
"GitRemote": "",
"GitUserName": "any",
"GitPassword": "myPAT", 
"GitBranch": "main",
"GitSyncBehavior": "TwoWay",
"ConfigurationScript": ""

I have tried changing the repo by working with Azure DevOps and Github but the issue keeps persisting unless I’m doing something wrong. Thank you

Product: PowerShell Universal
Version: 1.5.19

Can you try the following?

  1. Stop the PSU server
  2. Delete the repository directory (C:\ProgramData\UniversalAutomation\Repository)
  3. Restart the PSU server
  4. Check the branch status of the repository directory after the first git sync with git status

That appears to have solved it after deleting the whole repository directory and restarting the application. Ran git status and surprisingly it was in the main branch as desired. Thank you so much :smile: