[solved ]2.5 Spinning Circle

Updated my IIS files to 2.5 and loaded the same dashboard. But when connecting to the endpoint/computer I’m trying to manage I just get a spinning circle on my udinput window.

New-UDPage -name "Manage Computers" -Icon desktop -AuthorizationPolicy "allim" -content {
    New-UDLayout -Columns 4 -Content {
        New-UDInput -Title "Manage Online Computer" -SubmitText "Connect" -Content {
            New-UDInputField -Type textbox -Name "ComputerName" -Placeholder "Computer Name"
        } -Endpoint {
            New-UDInputAction -RedirectUrl "/domain/$ComputerName"

If i hit my dynamic page manually all the data comes up. however all my UDInputs are just spinning circles now. Something basic like this just hangs.

New-UDInput -title "Actions" -SubmitText "Run" -Content {
    New-UDInputField -Type select -Name "Action" -Placeholder "Choose your action" -Values @("Choose One","Restart")
} -Endpoint {
    if($action -eq "Restart"){
            restart-computer -ComputerName $computer -Force -ErrorAction Stop
            Show-UDToast -Message "Restarted $computer" -MessageColor White -Duration 5000 -BackgroundColor Green -Position bottomLeft
            Show-UDToast -Message "Failed to restart $computer" -Duration 5000 -MessageColor red -Position bottomLeft

Edit: Seems it was browser related /shrug. cleared IE defaults and started working >.<

Hello Justin did you unblock the files after downloading them?

which files? I just installed the module as I did the previous one.

What I did now was take my udinput for restart, and just launch powershell and created a dashboard outside of IIS using the normal module install and udinput works. Put that same page in my IIS dashboard and it just sits there with a spinning circle. I have my 2.4 folder and 2.5 folder separated so i can stop iis and load then individually if need be however 2.5 just doesnt work with udinput for some reason in my iis.

Here are some errors im seeing. In my iis logs i get.

2019-07-02 18:19:46 clienip POST /api/internal/component/input/570e9549-fbf2-4977-9ea8-1828e6adf51b - 80 domain\user Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/75.0.3770.100+Safari/537.36 http://dashboardserver/Manage-Computers 500 0 0 140

I see its getting a 500 0 0 error.

New twist, if i change the port to something other than port 80 it works. /headscratch

No other sites are running on any interface on that port, heck this is a dedicated IIS server for UD. All other sites are shutdown. 2.4 was running port 80 just fine. Moved 2.4 to 8080 and tried 2.5 on port 80 and just get the spinning circle on UD inputs when i hit the button. Moved 2.5 to port 8080 and UDInputs work no problem. >.<

When on the original port, try to refresh your browser with Ctrl+F5. It will avoid the browser cache and may work around the issue.

Thx, will try tomorrow when I log into work. Currently on vacation for the week, but I have problems letting go of things if they dont work lol.

1 Like