Secrets Vault Missing From "Add Variable"

I am unable to add any secret variables. When I click the drop down to choose my vault, it only says “No Data”.

My setup is being hosted via IIS and over HTTPS. WinServer 2019, PS 5.1 and 7.0.2. Used the zip package, unblocked all of the files. No other modifications, just trying to run my first job via the scheduler.

Can you upload a log? I’d be curious if there are errors regarding the secret module.

The logs default to C:\ProgramData\PowerShellUniversal

Here you go. This is from the first login of the day and me trying to create a secret. I have tried this in Firefox, Chrome, New Edge, IE. Both local to remote.

Weird. It’s almost like it can’t find the vault at all since there are no errors. Are you using a custom app pool user?

No, i am using the LocalSystem account.

I actually did test this in both IIS and the built-in server since it was easy enough to start and stop each. Both produced the same result of an empty vault.

Can you try to create a service account to see if you have the same result? In IIS settings, are you setting the Load user profile setting?

I did try it with a service account as well, same result. I have not set anything regarding loading a user profile.