Script running again without intervention?

I have a script that I ran in Universal Automation. I only ran the script once but I saw things showing up twice as if the script was run again. For example, at the end of my script I have a Send-MailMessage and it came twice. Also in the same script I have a foreach loop that outputs a report once done. Some, not all, of the reports showed up twice. Just wondering if this is expected behavior or if I am doing something wrong? When I run the script in powershell normally it performs as expected no double issues.

Thanks again.

That’s not correct behavior at all. Can you grab a log?

Are you scheduling the script at all or just running it manually?

This was a manual run, Get-DFSACLbatch.ps1

Logs from that day and not scheduled at all.!Aql0rufTI1IWld9orzDka645MeNg4A?e=U8c9BB


Thanks. Filed an issue and will look into it.

1 Like

Running 1.5.4 when this happened, have upgraded to 1.5.6.

I noticed from the change logs this may have been fixed? I am still seeing this. This script name is Get-HdriveSizes.ps1

I also have issues with canceled script running again or not stopping. They look cancelled but then I get the emailed report later that is generated on completion of the script. Also when upgrading the cancelled job would AutoStart with the service. I upgraded today to 1.5.6 and have to restart again to add a service account and both times the cancelled script restarted. The script name is Get-SharegetMigrationDetails.ps1

Logs Here