Scheduled Job not running / Unable to update concurrent job limit

Hey everyone

noticed this morning that two of my jobs hadn’t been running for a good few hours and i’m not entirely sure why
Seemed to last run at 2:05am and not again until i manually ran them

When trying to view more of the runs on 1 page I noticed that the drop down for specifying how many to show on one page doesn’t seem to work :frowning:


After this I rummaged around the settings and came across concurrent jobs in the general settings and noticed it set to 1 and wondered if that was maybe causing some of the other issues I was seeing.

when trying to change the concurrent jobs, it tells me that the setting has been update but if i try to amend to number it blanks out the box and then resets back to 1 after i refresh the page

Was using 1.2.8 initially today but updated to 1.2.10 and rechecked the issues mentioned, they are still present.


Hey, I’m not a user of the automation side/jobs or these settings but you could try the latest nightly as its on v1.3.0:

I’ll take a look at these issues today. I don’t think they are addressed in v1.3 as I hadn’t realized they were happening.

I can reproduce the concurrent job limit issue. I found that the database is set to 1000 so I don’t think that’s why your jobs weren’t starting. I can’t change it though in the UI. You can use something like LiteDB Explorer to check out the settings table to validate if you are stuck on 1.

On your schedule page, what does it say for the next execution time for your schedules?

I experience similar issues, updated to 1.2.10 now, and I can add a script to the schedule, but setting up another schedule is not populated on the “Schedule page”, but my “schedule.ps1” file gets two lines of schedules, but no other schedules are added.

Experience the same on two different environments.
Same issue on 1.2.9 and 1.2.8 from before.

Hey @insomniacc I actually meant to check that out last week but got caught up with other stuff and forgot :frowning:

@adam sure thing,

The next run execution currently shows NA / Runs one time

But the schedule.ps1 shows every 30 minutes

Also thanks for confirming the concurrent jobs :slight_smile:

This is fixed in 1.3. We’ll be releasing it in the next hour or so.

Fantastic, thanks @adam !

the only other thing I’ve noticed is that sometimes my endpoints either aren’t importing the data like they should or the grids/charts aren’t refreshing once the data is imported.

if i rerun the tasks manually the data displays fine though.

I’ll update to 1.3 and see if this is still the case.