PSU Docker SystemLogLevel

I try to follow the guidelines Optimizing API Performance in PowerShell Universal (
Running PSU in Azure Docker, I am trying to reduce the SystemLog level. I tried adding “SystemLogLevel” as name with value “Error” in the Azure Configuration but it does not seems to work, I continue receiving Info messages in the database.

What is the correct setting name I should apply?

Thank you!

Product: PowerShell Universal
Version: 4.1.8

What is the exact name of the service you are using, and how are you pushing your Environment variables?

I’m using Azure container Instances and ARM templates.

The environment variable for this setup should be something like the following:

	"name": "SystemLogLevel",
	"value": "Error"	

I use the Web app config:

I would have imagined that would have worked.

What is the contents of your appsettings.json file? Do you see the line in the file?

Maybe I am wrong. I try to optimize the API following the guidelines. What I see in the PSU database is millions of rows in “LogEntry” table. Everytime my Endpoints is consumed, several info logs are created. I want to disable this for perfomance and to reduce DB consumption.
In the article, there is the New-PSULoggingTarget -Type “Database” -Properties @{
} -Level “Error”
but it is not clear where I need to execute it.