Problems with changing Git repo

Good day,

I have to change the git repo and user PSU is using.
I had PSU 3.0.6 installed and git worked (We are using gitlab). Then changed simply appsettings.json param
GitRemote and GitPassword (which is a project api key)

"Data": {
	"RepositoryPath": "%ProgramData%\\UniversalAutomation\\Repository",
	"ConnectionString": "filename=%ProgramData%\\UniversalAutomation\\database.db;upgrade=true",
	"GitRemote": "https://****/psu/powershell-universal.git",
	"GitUserName": "any",
	"GitPassword": "****",
	"GitBranch": "",
	"GitSyncBehavior": "PushOnly",
	"ConfigurationScript": ""

This failed, so I went under “%ProgramData%\UniversalAutomation\Repository” and deleted
.git folder in the hope PSU will recreate it with the new repo, I didn’t worked.

Updated to the latest version 3.1.0, which has the new git function in the Dashboard.
Removed the settings from the appsettings.json and reconfigured it within the Dashboard with Git Settings. Start sync doesn’t do anything even when the Dashboard is showing the proper settings,
.git folder is still missing.

I believe PSU has the settings somewhere saved within his database which arnt consistent with the new settings, is there a way to clean the whole git settings up?

Product: PowerShell Universal
Version: 3.1.0

It should use the appsettings.json settings before considering the settings in the database. That said, you can use LiteDB Studio to edit the DB file and delete the GitSettings collection. This will revert it back to having no settings in the database.

I’ll also open an issue so we can add this funcitonality directly to the product.

Thanks for the link, with that and deleting the settings and status I was able to get it working aigan with reconfiguring appsettings.json.

Now I added also the new params to the config (actually I reinstalled psu and edited the newly created appsettings.json instead of overwriting) GitSyncInterval = 15, Which I believe is 15min? Still this value doesn’t seems to change something as within the db the status remains ~2 hours

I tried setting up via the GUI and set it to an interval of 15 but it just goes every min. Wonder if this setting is getting picked up.