PowerShell Universal Dashboard v3-beta1

Super stoked to announce the release of the first beta for UDv3.

Read more here :point_down:


Great news and looking forward to using it … Is v3 beta1 available to install using Install-Module -AllowPrelease?

Yep! Both community and enterprise are on the gallery.

Also, please feel free to file issues on GitHub. I’ve created a new label for v3: https://github.com/ironmansoftware/universal-dashboard/labels/v3

1 Like

Cool … I also recognised that the authentication and authorisation doc is missing ind the azure doc. Are there any changes in the background logic how to use it?

Same question for pages and dynamic pages!

The only big change is the removal of roles but the Authorization Policy and Authentication Method cmdlets remain the same.

We will be introducing more customization for the login page but it will likely just be more cmdlets and not less.

For pages, they are one of the cmdlets that still has Content and Endpoint so they will behave the same as before.

Perfect, no more question to start try out v3 … once again great work and a big step to a big improvement for this project.

1 Like

It seems that I cannot add the v3 label to my issues:

Hmmm ok. I thought anybody could put tags on there but I guess not. I dont see any option to enable it.

Fine … i thought maybe i cannot find it …

Tried to install V3 and got this? Am I missing something?

Install-Module -Name UniversalDashboard -AllowPrerelease
Install-Module : A parameter cannot be found that matches parameter name 'AllowPrerelease'.
At line:1 char:41
+ Install-Module -Name UniversalDashboard -AllowPrerelease
+                                         ~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (:) [Install-Module], ParameterBindingException
    + FullyQualifiedErrorId : NamedParameterNotFound,Install-Module

You will need to update to the most recent version of PowerShellGet before installing a prerelease module.

1 Like

What are the system requirement for V3? Will it work with Powershell 5.1 ?

Yep. It will work with PowerShell v5.1,6 and 7. It has the same system requirements as v2.

Hello, there is different hierarchical folder path versus 2.9.0 module. I tried to update it in my Azure App but it doesn’t work.

I haven’t gotten to the docs for v3 Azure hosting. We are hosting v3 here: https://universaldashboard-dev.azurewebsites.net/

The web.config should remain the same but you will have to make sure it’s at the root folder.

<?xml version="1.0" encoding="utf-8"?>
    Configure your application settings in appsettings.json. Learn more at http://go.microsoft.com/fwlink/?LinkId=786380
      <!-- <requestFiltering removeServerHeader ="true" /> -->
      <add name="aspNetCore" path="*" verb="*" modules="AspNetCoreModule" resourceType="Unspecified" />
    <aspNetCore processPath="PowerShell.exe" arguments="-File dashboard.ps1"  />
        <remove name="X-Powered-By" />

Here is the dashboard.ps1 we are using. Note that we are currently hosting Community edition.

Import-Module "$PSScriptRoot\UniversalDashboard.Community.psd1" 
$Dashboard = . "$PSScriptRoot\poshud\dashboard.ps1"
Start-UDDashboard -Wait -Dashboard $Dashboard

Hello, I mean i had UD premium license and my actually folder path in v2.9.0 module was (+ personal data in Azure WebApp):

Versus in new v3.0

There are 2 folders in:
/UniversalDashboard.Community has:
Like actually hierarchy folder path in 2.9.0 but it’s community edition,
and the other one,
/UniversalDashboard.Enterprise has:
Just these content…

In case to upload my Azure webApp I have to take this folder to in (what folder in this case, community?)


We can make it work with the two folders. Upload the 3.0 version with the 2 folders. Move the web.config to the root. So it’s in the same folder as UniversalDashboard.psd1.

Put the dashboard.ps1 in the same folder as UniversalDashboard.psd1 and make sure to load it from there:

Import-Module "$PSScriptRoot\UniversalDashboard.psd1" 
Start-UDDashboard -Wait -Dashboard $MyDashboard

I will make sure to add a web.config to the UniversalDashboard module so you don’t have to copy it around.