PowerShell Universal 1.5

We’ve released version 1.5 of PowerShell Universal! This release includes a lot of cools things many of you are already kicking the tires on.

Read more: https://blog.ironmansoftware.com/powershell-universal-15/


UDTable is just awesome! thank you for your work!!!


I have been silently running the nightly versions on my Mac (with a few tweaks to the psm1 file and the VSCode plugin) but now that there is official support, what is the preferred method on installation? I don’t see an official install on the downloads page. Will you be adding one?

I see it on the link!


Whoops. I will get that added to the downloads page!

Can you send me the tweaks you had to make to the PSM1 and VS Code extension? We can integrate those.

Sure! It was mostly obvious things like adding ‘Darwin’ as a type of OS and some other things, I assume you’ve done most of those things in this version so let me see what’s different and I will send you what I’ve got.

Also for some reason the Zip file is odd on all of my machines. The files have the folders in the filenames. So there are no folders in the zipped archive. I am using a few different types of extractors and they all show the same thing… example…


is the entire file name and not nested in the folders that are in its name. I am running a script that corrects it, but I just wonder if I am the only one with this issue.

weird. Ok. I’ve add this to our backlog to get corrected! Thanks for the feedback.

Update looks good, thanks for the effort creating this product!! butt when i updated my install (msi install on windows server). My appsettings.json got reset to default value’s.

You can avoid this by putting the appsettings in the ProgramData folder. https://docs.ironmansoftware.com/getting-started/upgrading#appsettings-json

That is something that will need to be worked out with the MacOS version. Where to install the Universal.Server application and files. Permission issues arise if its placed in the root user folder, but seem to be okay if placed in the Documents folder inside the powershell profile folder. I haven’t tried installing on a linux system, but I assume some of these things might align.

Also strangely using the PowerShell Expand-Archive cmdlet unzips the file just fine, while other tools seem to have an issue.