Packaging in VS Code remove POSH profile befor

i am trying to package my script into an executable for the first time. after getting all of the prereqs installed and the exe built successfully. but when i run it i get an error about not being able to load the POSH profile due to execution policy. FYI the script is singed with a valid code cert.
Since i dont want the exe to attempt loading my POSH profile on other machines, is there a way to exclude the profile from the build? i couldnt immediately find a setting in the package.psd1 for that option.

Tool: Visual Studio Code, PSScriptPad, PowerShell Module

You can use the PowerShellArguments property to set any argument that you would normally pass to PowerShell.

You should be able to do:

PowerShellArguments = "-NoProfile"

The docs are super light on this setting so I’ll add a new example when I get a moment.

Awesome. thank you very much.