New-UDGrid - pagination oddity

Hi There

Using UD 2.5.0 on OSX with Powershell Core

When I load a grid with about 280 items I always get pagination navigation links on the bottom of the grid. Does not matter when I filter and have only 5 items left, the amount of pages I can navigate to stays the same. When I click on any page number I get an empty grid and when I to run to page 1 I get the filtered 5 back in view. Is this supposed to happen like that? Is there a way to get rid of that pagination strip at the bottom of the grid? Or perhaps when the filter is active and the amount of items is less than the defined or viewable rows in the grid the pagination disappears?

I tried the “NoPaging” option but that did not get rid of the navigation strip/pages at the bottom. I did get a large list of items but could still navigate through the same amount of navigation pages as when the option was not used.

Hi @Steven I believe this is now fixed, Adam even pushed out 2.5.2 so update and should be resolved. If you have not done so already


Thanks for the heads up!

I updated to 2.5.2

The result is a bit better but still there is an issue in that when I filter the number of pages in that pagination row remains the same.

So I start out with 7 pages of records, I filter so only 2 records remain, the pagination still says I have 7 pages of data.

Maybe that is expected behaviour?

When I use the option “NoPaging” option I still get all the page numbers below the rows and when I click on one of them, the list becomes empty.

When I click page #1 again the data/rows return

It can also show 1 page number too many in some cases (I set the page size to 3 with the same data set and I get 23 page numbers but when I click 23 the grid is empty)

Also, it would be logical to show page #1 as an option once the pagination “bumps” page #1 so you can quickly go back to the starting page

When I click the left arrow (the “<” symbol) quickly all the pages have this bleu “activate” background, as if I selected all the page numbers, I that makes sense?

Using the -FilterText ‘MyFilterText’ parameter yields the exact same text as before, the text “MyFilterText” does not show

Using the grid on a row, column, card structure I experience that the grid is empty for some reason but placing the same grid outside the row, column, card structure show the grid as it should be. Could be my own fault
but I have not yet figured this one out.

Ok, this is starting to become a complaint/wish list kind of ramble and this is not the place to do so I think

Again, much appreciated in the heads up of the update being available!

Met vriendelijke groet / Warm regards,

Steven Spierenburg

I can confirm I get the same result in a UDGrid on 2.5.2 (IIS and Console), pagination doesn’t change when filtering. When I use a ServerSideProcessing UDGrid the pagination is correct which makes me think that the totalitems variable isn’t changing (assuming such a thing exists in a client side processing UDGrid).
In addition, in a ServerSideProcessing UDGrid choosing a page number does nothing until the refresh button is clicked. Can anyone replicate that?

confirmed, same thing here, if i have one page of results, i get pagination from negative pages to like 1 or 2, its very weird. 2.5.2 on IIS.

I have opened a bug for this issue: