New Custom Component not registered


I’m trying to make my first custom component. I downloaded the master template from here and used the Plaster option UD.Build.ps1 as it is, no modifications or weird stuff, just as it comes.
So far, so good. It does run without errors, and the test dashboard runs perfect, but if I run it in another dashboard, it shows that the component is not registered. If I run the test one, it does work.

I am importing the new module.

I think I might be missing something. This is like Chinese to me, but NO SACRIFICE, NO VICTORY.



This is what I missed the first time with the same error

First custom component - Component not registered

1 Like

I got you missed [UniversalDashboard.Services.AssetService]::Instance.RegisterFramework.
But what should I put between ()?

This is what i used for a Semantic UI component.

# Register the main script and get the AssetID
# $AssetId = [UniversalDashboard.Services.AssetService]::Instance.RegisterScript($IndexJs.FullName)
$AssetId = [UniversalDashboard.Services.AssetService]::Instance.RegisterAsset($IndexJs.FullName)
[UniversalDashboard.Services.AssetService]::Instance.RegisterFramework("Semantic", $AssetId)

As far as I understood its just a random name (e.g. display name), not used in any other logic.
I am new to custom components, but worked for me.

1 Like

So, the basic is now working! Thanks augustin.ziegler. No I need to understand what the f*ck I’m doing. LOL

1 Like

had exactly the same starting problem … what are you planning to build?

I’m trying to understand what I’m doing first. I have a couple of ideas, I go to and have a lot of components. Now I need to figure out how to put it in UD. I truly don’t understand a thing about JS.

same here but still interested in doing something in UD … if you need some additional eyes just drop me a line. maybe I can help

Thanks! I believe I need a lot of Google yet. :laughing:

1 Like

Or a lot of UDForums :slight_smile: