License and Developer License - docker container is no longer reachable

Product: PowerShell Universal
Version: 3.7

I bought a license and could add this to PSU, which is running in a Docker container. I generated a developer license, removed the real license and tried to add the developer license. Something went wrong and I cannot reach my PSU instance anymore. Logs from Docker show the server seems to be started but navigating to localhost results in no website/PSU.

Is there anyway to ‘reset’ the license part of the container so I can start over with the license?

And what is the right way of using developer licenses? I thought you’d have a real license, create a developer license, remove the real license and import the developer license was the way to go.
The goal is to have a local running development container and a ‘real’ container using the real license. If my understanding is wrong then please correct me.


@adam I have a license I bought but am stuck. I waited for a while now to see if this can be resolved but no message or help offered.

Please tell me how to get support if the forum is not meant for this type of question.

I have to say that I am a little bit surprised that this takes 20+ days and still no answer on a license issue from a customer. What did I do wrong?

If you do not receive feedback on the forums, please reach out to Honestly, with any licensing question, I would prefer you open a support case so we can get it addressed as soon as possible. Not being able to use cool software for something license related is something I really dislike.

For your issue:

You are running into this: Container (Docker) support for developer license · Issue #557 · ironmansoftware/issues · GitHub

To reset the license state, you will need to either reset the DB file or edit the DB file remove the license from the license collection. if you are using SQL for data persistence, you will need to remove the license from the license table. If you want additional assistance in this matter, please email

Hi Adam,

Understood, for that type of support I will open a support case from now on.

And thanks for the help!