IIS - Automation Engine not starting after App-pool stop-start

Product: PowerShell Universal
Version: 2.10.2

I’ve got all of the correct IIS setting in my app-pool and the Automation works flawless throughout the day. But I have a scheduled task to stop and start the App-Pool overnight and have been able to confirm via jobs that once the task runs the Universal Server is stopped until I load it manually the next morning.

What I’m wondering is if anyone has been able to start the Universal Server up again via a scheduled task after the App-Pool is started? I think that is a good workaround for this I’m just not entirely sure how that works in IIS since the Universal Server is not a standard process.

I’m thinking I can just add it to my current scheduled task to restart the App-Pool overnight.

$applicationPoolName = 'APP_POOL'

if((Get-WebAppPoolState -Name $applicationPoolName).Value -ne 'Stopped'){
    Write-Output ('Stopping Application Pool: {0}' -f $applicationPoolName)
    Stop-WebAppPool -Name $applicationPoolName
}

Start-Sleep -Seconds 30

if((Get-WebAppPoolState -Name $applicationPoolName).Value -ne 'Started'){
    Write-Output ('Starting Application Pool: {0}' -f $applicationPoolName)
    Start-WebAppPool -Name $applicationPoolName
}

# Add in Universal Server remote start up here

Anyone had any success with this?

Hi, did you manage to fix this issue? I have the same issue (and settings). After a reboot, the application pool is in state stopped. After manually starting it, the application responds

I’d recommend setting the app pool settings listed here to ensure the app pool comes up automatically: IIS - PowerShell Universal