Git Sync Branch Select Issue

Product: PowerShell Universal
Version: 1.5.13 (Ubuntu Docker)

Has anyone been able to get the Branch select working with Git Sync? I’m using Azure DevOps private repo. I don’t have an issue when I don’t set the GitBranch property and it pulls from master, but when I try to select a branch, it doesn’t work and I get these errors in the logs


I tried different branches getting the same issue. PAT is valid as it does pull master when I don’t provide a branch to PSU.

just tried on 1.5.14 same error.

Hmmm seems like a bug. What happens if you run git fetch in the repository directory? Does it still have that issue?

I attach to the command line in the docker, browse to the Repository directory, but git isn’t recognized in there, unless I’m doing something wrong.

Also, something else that’s strange, some data seems to be pulling from my repo but not from the branch I selected, but from the master branch. It’s not an active sync as I have to destroy the container and re-run it for it to pick up changes (again not from the branch I selected but changes in master).
Hope I explained that well.

Ok. I’ll open an issue for this. It seems like something isn’t right.

1 Like

Hi @adam do you haven an idea about when this might be fixed? If you’d like me to submit the bug on the GitHub page, I can. I was going too, but wasn’t sure if you already had an issue tracking for it. Thanks for the help.

It was released a couple of hours ago in 1.5.15. :slight_smile:


1 Like