Form with Textarea not in "body"?

Hey all,

anyone know how to do this?

 New-UDForm -Content {
    New-UDHtml -Markup "<textarea Rows=`"$($GameContent.Length)`" TextMode=`"MultiLine`" style=`"width: 80%;`" id=`"content`" name=`"content`">$($GameContent | out-string)</textarea>"
    New-UDCheckBox -Label 'test'
    } -OnSubmit {
    Show-UDToast -Message ($Body | ConvertTo-Json)
    }

the $Body here only contain the Checkbox.

This won’t work with the form because the UDHtml isn’t going to integrate with the form context automatically.

I just added -Multiline to New-UDTextbox so you’ll have access to that in 1.4.

is it in the nightly tonight? :slight_smile:

It will be in tonight’s nightly. I just put it in this morning.

1 Like

so, nothing get renderen with the -multiline switch.
I have done a full browser clear cache.
did I do a bad job, or is something missing?

Can I have Rows and Rowsmax also? :smiley:

okey, now it seems to be some weird stuff here…
so it seems I have the “module” in more places, but it’s not updates in all the places:
C:\Program Files (x86)\Universal\UniversalDashboard\Frameworks\v3 (Updates)
C:\ProgramData\PowerShellUniversal\Dashboard\Frameworks\UniversalDashboard\3.1.0 (NOT updated)

what to do here ?

You need to delete the program data one and restart the UD restart. It will redeploy the new stuff. More info on that here: https://docs.ironmansoftware.com/getting-started/upgrading#dashboard-components-and-frameworks

I’ve added Rows and RowsMax to the next build.

omg, endusers right? :smiley:

so it seems I have not tested with nightly at all, but I get alot of errors now :smiley:

[09-29-20 04:14:12 PM] Startup: Cannot find an overload for “Register” and the argument count: “3”.

[09-29-20 04:14:12 PM] Startup: at New-UDPage, C:\ProgramData\PowerShellUniversal\Dashboard\Frameworks\UniversalDashboard\3.1.0\UniversalDashboard.MaterialUI.psm1: line 2436

at , C:\ProgramData\UniversalAutomation\Repository\ServerManager\Server Manager.ps1: line 8

at , : line 1

[09-29-20 04:14:12 PM] Startup: at CallSite.Target(Closure , CallSite , Endpoint , String , String , PSScriptCmdlet )

at System.Management.Automation.Interpreter.DynamicInstruction`5.Run(InterpretedFrame frame)

at System.Management.Automation.Interpreter.EnterTryCatchFinallyInstruction.Run(InterpretedFrame frame)

Known error?
this is thrown by New-UDpage

New-UDPage -id “Pageid” -Name ‘Game.ini’ -Url “/gameini/:Id” -Content

this is the today nightly, im sure you just point me to something simple :smiley:

That overload was added in a recent build. Are you installing an MSI? You’re the second person to see behavior not change after upgrading to the nightly.

Investigating…

yeah this is installed by the MSI

Did you just run the MSI after installing or did you uninstall the previous version and install the new one?

I think the MSI is leaving behind old files if you try to upgrade. I just ran a clean install and I do not see this error. Can you:

  1. Uninstall current version
  2. Make sure C:\Program Files (x86)\Universal is empty
  3. Install new version

Do I need to backup my dashboard before ? or will it leave the files alone?
I am trying to see if it’s a “pending file rename” as the dashboard were running while installing the new version.

It won’t touch your dashboards or the database. If you want to back anything up, they are in %ProgramData%\UniversalAutomation.

uninstall and reinstall worked!
it seems the codeeditor make reference to the root folder ? and not the dashboard “subpage” ?

Cool!

That’s a bug with the code editor. Just fixed it.

1 Like

you on Fire man!

Thanks for empowering me!

btw,
this:

dont work ? the (get-UDE) return a hashtable, and not a “object” ?
I got it working with this:
(Get-UDElement -id ‘Editor’).code

(Language I have used i “Ini” dont know if that make af different?)

and it seems the compare feature is broken ?
I get this error:

Error: Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args[]=ReferenceError%3A%20state%20is%20not%20defined&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.

in p
in ForwardRef
in ForwardRef
in div
in ForwardRef
in ForwardRef
in div
in ForwardRef
in ForwardRef
in ForwardRef
in ForwardRef
in u
in Dashboard
in t
in t
in div
in t
in t
in n

this error is with the code editor in a modal, if I move it out of the code editor I get this:

I just committed a fix for the diff tool.

1 Like

where do I retrieve the new version?
the marketplace is 1.0.2, the nightly is still on 1.0.3 ?
https://marketplace.universaldashboard.io/Dashboard/UniversalDashboard.CodeEditor

The version didn’t get updated. This has been fixed in 1.4.2 and 1.0.4 of that control should be available