Exception calling "GetSteppablePipeline" with "1" argument(s): "The parameter is incorrect."

I just discovered Universal Dashboard a few days ago and have run headlong into a problem I can’t resolve. I was working on converting an older script that allowed our helpdesk to generate historical reports of user lockout events for troubleshooting to a Dashboard.
I’ve stripped down my code to it’s most simple and this causes an error toast to appear with the titular error. Where am I going wrong?

$cert = Get-ChildItem -Path Cert:\LocalMachine\My\* | Where-Object {($_.Extensions.EnhancedKeyUsages.FriendlyName -eq "Server Authentication") -and ($_.NotAfter -gt (Get-Date))} | Select-Object -First 1
$content = {New-UDDashboard -Title "Investigate User" -Content {
    New-UDInput -Title "Input User" -Endpoint {
            $ADUser = Get-ADUser -Identity $ACID
            if ($ADUser) {New-UDInputAction -Toast "$ACID will be researched." -Duration 5000}
            else {New-UDInputAction -Toast "$ACID will NOT be researched." -Duration 5000}

$Arguments = @{
    Content = $Content
    Port = 10000
if ($cert) {$Arguments.Add("Certificate",$cert);$Arguments.Add("HttpsPort",10001)}
Start-UDDashboard @Arguments

Hi @blueflame78504 and welcome to the forum.
I tried your code and for me it’s working like expected, i am getting a valid toast that the username i searched will be researched. (If i use a wrong username that does not exist, an error message pops up).
I only changed the the $cert to one of my local certificates (Just changed the Where-Object part).

What version of UniversalDashboard and Powershell you are using? (I am using Powershell 7.0 and UniversalDashboard 2.9.0 in the below screenshot)
Are you using powershell remoting for testing your code? I know the problem in combination with Powershell remote sessions (Enter-PSSession, New-PSSession…)

I just downloaded it, so it is UniversalDashboard.Community 2.9.0 on both boxes I’m working on.
I was writing the code in VSCode and executing it there (Windows 10 & PS7), but I was also executing it on the server it will eventually run off of (Windows 2016 & PS7), hence the optional cert check.
Interestingly, when I run it in PS5.1 it works without error on both boxes. So that’s a good start.
However, in VSCode, I’m now getting a debugger error when trying to use PS5.1

Application startup exception: System.MissingMethodException: Method not found: 'Microsoft.Extensions.Logging.ILoggerFactory NLog.Extensions.Logging.ConfigureExtensions.AddNLog(Microsoft.Extensions.Logging.ILoggerFactory)'.
   at UniversalDashboard.ServerStartup.Configure(IApplicationBuilder app, IHostingEnvironment env, ILoggerFactory loggerFactory, IApplicationLifetime lifetime)
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at Microsoft.AspNetCore.Hosting.ConventionBasedStartup.Configure(IApplicationBuilder app)
   at Microsoft.AspNetCore.Hosting.Internal.WebHost.BuildApplication()

FWIW, I do get this warning in PS7:

WARNING: Module ActiveDirectory is loaded in Windows PowerShell using WinPSCompatSession remoting session; please note that all input and output of commands from this module will be deserialized objects. If you want to load this module into PowerShell Core please use 'Import-Module -SkipEditionCheck' syntax.

I guess I’ll just be writing an VSCode and copy/pasting into a PS5.1 shell. How odd, but I guess, if it works?