Error Executing Job

Product: PowerShell Universal
Version: 3.3.1

I sporadically get an error when running a Script.
I really on use the Powershell 5.1 Environment

Error executing job: Did not receive port from client process.

This can be the result of the server being slow to respond. This especially the case if it happens sporadically, like you mentioned.

I would suggest increasing the JobHandshakeTimeout setting. By default, PSU will wait 5 seconds for the WinPS process to respond. You can change this setting in appsettings.json.

  "UniversalAutomation": {
    "JobHandshakeTimeout": 5,

I also just remembered this setting is in the settings page in the admin console .

1 Like