Did not receive port from client process

Product: PowerShell Universal
Version: 2.7.4

So my setup right now is very basic. I have 1 script so far and it was to invoke a webapi and return some data, was working great. I hadnt used it in a while, like a month or so and I came back and now its not working. Script keeps returning “Did not receive port from client process” when it fails. I thought maybe the script needed to be fixed and just made the script RETURN “test” and even that has the same error.

I had the app pool running as a domain user, so I moved that to system and restarted, then ran the script again (shows running as my AD account), the RETURN “Test” script, and still the same error. Has anyone seen this or know whats going on?

Also tried PS 5.1 and 7.2 as the environment.
Just upgraded to 2.9.2, same result


Seems if I use the integrated environment I can get the script to run, but I need to use 5.1 for a certain script and cant get anything to run under 5.1. Is there a trick to it?

There isn’t a real trick to this. it may be a problem with the PSU assemblies being loaded into the WinPS process. This could be because of a missing .NET framework version or something else. Can you grab a log?

The problem here is that PS is starting but is not responding back to PSU after doing so. This can happen under load but it doesn’t seem like the problem in this case.