Error: Did not receive port from client process

I just cannot manage to make UA working.
this is the log.

info: UniversalAutomation.ExecutionService[0]
Error executing job 25: Did not receive port from client process. at UniversalAutomation.ExecutionService.ExecutePowerShell(Script script, IEnumerable`1 parameters, Job job, Schedule schedule, Int32 port, ExecutionCallback callback) in D:\a\universal\universal\src\UniversalAutomation\Services\ExecutionService.cs:line 399
at UniversalAutomation.ExecutionService.TryExecute(Job job, Schedule schedule) in D:\a\universal\universal\src\UniversalAutomation\Services\ExecutionService.cs:line 290
at UniversalAutomation.ExecutionService.Execute(Job job, Schedule schedule) in D:\a\universal\universal\src\UniversalAutomation\Services\ExecutionService.cs:line 151 System.Exception
info: Universal.Server.Services.ClaimsEvaluator[0]

I get this error when trying to run a simple script “get-service”
My setup is like this:
Window server 2016 running on AWS. Computer is joined in domain. User groups are setup on the server.
UA running in IIS: made the setup in the docs. can authenticate with windows auth.
UA not in IIS (right click on exe -> run as administrator) : can authenthificate with windows auth.

Problem is this one: I can’t run scripts in UA. " Error executing job: Did not receive port from client process."
Same error if i run UA from .exe or if run it in IIS.

Please help.

Also as a rant:
So time consuming just to setup the UA and UD on a server. Docs are few and they contradict with the answers on the forum. I’m really tired for every problem to come to the forum and make a post hoping to get an answer. Please @adam @adamdriscoll invest more time in the docs and tutorials.

Can you please enable Debug logging? Something is going wrong in the PowerShell process:

As for documentation, we are adding new documentation nearly every day so if there are gaps or inconsistencies, please let us know by filing an issue:

We are trying to ensure that most questions that are asked on the forums related to the function of PSU are translated into documentation.

Did the logging bit. here is what is shows in event logs when i start the app in IIS:

frst error: (source .NET Runtime)

Category: UniversalAutomation.Services.UniversalConfigurationService
EventId: 0

Failed to read configuration file. variables.ps1

System.NullReferenceException: Object reference not set to an instance of an object.
at Universal.Server.Services.ApiProxy.StopAsync() in D:\a\universal\universal\src\Universal.Server\Services\ApiProxy.cs:line 133
at UniversalAutomation.Services.UniversalConfigurationService.Read[T](Func`2 includes) in D:\a\universal\universal\src\UniversalAutomation\Services\UniversalConfigurationService.cs:line 460

Followed by information log: (Source IIS AspNetCore Module V2)

Application ‘/LM/W3SVC/5/ROOT’ started process ‘5740’ successfully and process ‘5740’ is listening on port ‘13747’.

Followed by Warning log: (source .NET Runtime)

Category: Microsoft.AspNetCore.HttpsPolicy.HttpsRedirectionMiddleware
EventId: 3
ConnectionId: 0HM3LOQ94IMTM
RequestId: 0HM3LOQ94IMTM:00000001
RequestPath: /
SpanId: 3f074b688604f842
TraceId: 777f7aad6ac50649a350372f25672c66
ParentId: 0000000000000000

Failed to determine the https port for redirect.

Versions of .net

.NET Framework Product Version Release

v2.0.50727 2.0.50727.4927
v3.0 3.0.30729.4926
Windows Communication Foundation 3.0.4506.4926
Windows Presentation Foundation 3.0.6920.4902
v3.5 3.5.30729.4926
Client 4.8 4.8.03761 528049
Full 4.8 4.8.03761 528049

This setup is running an apppool as local system.



also, windows firewall was disabled, network rules on aws allows all the inbound/outbound traffic.

Pool settings :
Basic Settings:
Advanced settings:

Site settings:
basic settings:

advanced settings:

this is the log from the moment i hit the “Run” button to run a script in UA dashboard: