Dashboard showing service account user while using runas


I am running dashboard as a user created under variable in PowerShell Universal.

Dashboard has a button which outputs whoami and I thought I would get the user who is running the dashboard in the button but instead of getting username of the user running the dashboard I am getting username of the service account used by the server.

Is it normal or I am using wrong command to get the user running the dashboard.

Are you using an external environment (non-integrated) for this dashboard?

Nope,using default environment.

If you are using the default integrated environment, it won’t start a separate process and will not be able to run under alternate credentials. Can you try switching to either the Agent, 7.x or WinPS environment to see if that resolves the issue?

Here are the setting on the dashboard.

Still getting service account in the dashboard.

You may have tried this but can you try to restart the dashboard and try again? I think change the environment may not restart the dashboard if auto deploy is on.

@Adam whenever I try to restart the dashboard after switching the environment and running as different
service account I get following error.
Dashboard 27; Request failed with status code 500

Got the same error at version 4.2.13 & 4.2.14.

Any help?

Were you successfully running dashboard with different
service account prior upgrade to 4.2.13 or 4.2.14 or this was the first time to tried to use runas?

At version 3.x ot work fine with runas.

Have you checked if variables you set has changed after update?