"502 Bad Gateway" from API when script takes to long


We are using UD to provide our unix folks with some APIs that allow them to work with MS technologies. One of these is DNS, where we want to make sure that any changes are reflected on all DCs in our site. As it sometimes take longer, script sometimes looks like it hanged and API responds with 502.

We are hosting UD in IIS.

The question: any way we can prevent UD from responding with 502? I’ve already added time-bomb in the script that will not wait forever for AD sync, but it looks like it was not good enough. I’m open for any suggestions!

Kind regards

1 Like

Have you solved this issue? I’m getting the same here

Same problem here, just doing a POST to endpoint and sometimes it will take 3min+ to process req - but IIS always return “IIS 10.0 Detailed Error - 502.3 - Bad Gateway…” after 2min+.

I think you need to tweak the IIS website settings: asp.net - How to increase request timeout in IIS? - Stack Overflow

I don’t think PSU is actually timing out.