Unable to start Powershell Universal Service on Windows

Product: PowerShell Universal
Version: 1.5.3

Background: This was a new install from the MSI and everything worked just fine after the install. All that was created was 1 API endpoint for testing.

Issue: After a Windows Update and a reboot, the Powershell Universal Service will not start. Note that after the install, I didn’t try restarting the server or the service so it’s hard to know if it is related to the Windows Update.


  • Below are the Windows Event Viewer events related to the service not starting and the log file entry.

  • I did try deleting the database.db file, but this had no effect.

  • The settings.ps1 and endpoints.ps1 files that logs say cannot be read are there. They had been opened, but not changed, with the VS Code Powershell Universal Extension

Screen Shot 2020-12-09 at 9.38.26 AM

Are there scripts in those files that are 0 KB? If not, I would try deleting them and attempting to start the server.

@adam Thanks, that worked to move everything out and then start the service. I was able to recreate the issue by shutting down the service, opening up the VS Code Powershell Universal extension, then clicking on the open icon next to the setttings.ps1 file. When I closed this file, it created the 0 byte file. Afterwards, I could not start the service or start it through the VS Code Extension.

I just had the same exact issue occur for me. Not sure if its a bug or something of my own doing.