Unable to install Modules (Edit; ExchangeOnlineManagement seems to be the issue)

I seem to have somekind of gift that I run into issues with PSU every single day :sweat_smile:

I can search for a module in PSU, install it, and get a confirmation that it has been saved.

PSU list the module as available to all environments

But the module is not available, and not to be found in the path

Product: PowerShell Universal
Version: 3.5.4

Running PSU as LocalSystem does not affect the issue.

I can install the module just fine manually on the server.

The AzureAD Module is being installed just fine.

Modules installed through PSU, will disappear from the Modules page after service restart, but will still work.


Manually pasting the exchange module into the Module path also works, but it also does not appear in the modules admin page.

I run around the same issues, but with more modules also Mdbc for example.
I believe it has something to do that thus modules are missing a .psm1 file in the root directory.

As a workaround, you can manually copy the module directory to the … Repository/Modules path and add them to environments just regularly.

For the problem that the Exchange Module, dunno why it isn’t event get installed, but as stated, copy the whole module folder works for this

Also running Connect-ExchangeOnline via script will hang at

VERBOSE: Returning precomputed version info: 3.0.0
VERBOSE: ModuleVersion: 3.0.0

dunno why

I usually just install modules onto the system computer.
Doing so requires a restart of the PSU service.

Used to do this, but that makes updating modules a pain as other users might be logged onto the server and using the modules :slight_smile:

in 3.6.2, modules are now being installed, but after service restart they still disappear from the list of installed modules. @adam

Hmmm. I am seeing it actually fail to install this module. I’m just running as my local user. I already have EXO installed in the system but not in the module directory.

Let me play around with it and see if I can figure out what’s up. I have a feeling it’s throwing some sort of error silently.

1 Like

I can reproduce the issue where the module won’t be listed after start up and found the issue. It will be resolved in 3.6.3.

1 Like