Secret Scope in v3.0.1

Good day,

I have upgraded from 2.9.3 to 3.0.1 successfully.
But I had problems to get the Secret variables running in Endpoints and Scripts.

In settings, I have currently

	"Secrets": {
		"SecretStore": {
			"Password": "PSUSecretStore"

Which I have also used after the update. Thought I believe, BuildInLocalVault does not use this password to encrypt stored passwords.
Secrets are stored however in BuiltInLocalVault and I access them simply by using the Variable Name.

Simply using the scope $secret:Credential did not work, Variables remain empty.
Recreating Secrets in BuildInLocalVault or PSUSecretStore did not work, Variables remain empty.

I have also installed a fresh instance on a test vm and simply tried to use secrets, but neither there it worked. What do I miss?


Product: PowerShell Universal
Version: 3.0.1

I can reproduce this in endpoints. The problem is that the Universal module is not being imported for some reason.

I opened an issue here.

I was able to work around it by importing the module manually first.

Import-Module Universal