New-UDImage - Has something changed?

Trying to do a New-UDImage inside a card and no matter how I specify the image path, it does not work.

i.e., The ways I have tried.

(New-UDImage -Path '')
New-UDImage -Path '/images/theImage.png'
New-UDImage -Path '../images/theImage.png'

The folder is published and using the Advanced Card with New-UDCardMedia -Image, it works.
I can even copy the path into my browser, and it will navigate to the image just fine.
Published Folder has authentication turned off.

Am I doing something wrong?

Product: PowerShell Universal
Version: 3.9.4

EDIT: Tagging @Support

If you use a URL, you will need to use the -Url parameter.

New-UDImage -Url ''

For the path, it seems to work for me.

New-UDImage -Path 'C:\src\blog\content\images\71-pack.png'

You may want to use the $Repository variable rather than a relative path.

New-UDImage -Path "$Repository/images/theImage.png"
1 Like

Weird, I tried with the URL, and it did not work for me.
I at first tried using the relative path, but that failed.