New-UDDashboard -Pages version 2.7 issues?


I updated my dashboard from 2.4 to 2.7 (licensed / running on IIS) and my navigation bar is gone and I can’t open any sites anymore beside one. I have a json configuration file which provides every page. the syntax in that json file looks like this:


then, the whole string gets split and load into the $pages variable. this is my code which was working in version 2.4.

$option = [System.StringSplitOptions]::RemoveEmptyEntries

$pages = @()

$confPages | ForEach-Object  {
    $_.split('|', $option) | ForEach-Object {
        $pages += . (Join-Path $PSScriptRoot "pages\$($_)")

then I just created a new dasboard like this:

$db = New-UDDashboard -Title "here is a title" -Pages $pages ....

and everything worked perfectly. but with version 2.7 I only get the first page of my above mentioned string and that is “home.ps1”

I tried to debug this scenario and so I put the $pages variable into the

New-UDEndpointInitialization -Variable "pages"

the $pages variable knows of every of my pages but is only creating a URL for the first one. In my case its '/Home' I have a page for testing but according to $pages there was no Url created and the Property ‘Dynamic’ tells me, its ‘False’ but ‘home’ is dynamic.

Did I miss something in the new version? According to the documentation UD Docs the navigation menu gets created automatically:

By default, when new Pages are added to a dashboard, a navigation menu will be created that provides access to all the static pages. Dynamic pages will not show up in the navigation menu.

Any help is appreciated.


Did you completely delete the files out of the folder? If you copy the new module over the top of the folder you will have problems.

Hi Adam,

I created a new Folder especially for 2.7 and just added my files from 2.4. I just did it another time and still having the same problem.

I will do some tests today. I will keep you updated.


update: I figured it out. I ran into the same problem as described in this post. It’s because of the buggy ClaimsPrincipal. But $Users isn’t working for me either: