Blank Admin Screen

Installed the licensed version of UD 1.2.9 on a 2012 R2 server with PS 5.1.14409.1018 and .Net 4.72 using the built in web service and not IIS. Created a few working API endpoints and was off to the races w/o any issues. Was working fine Friday but back to work on Wednesday I have a blank admin screen using IE or Chrome. Tried restarting the service, rebooting and reinstalling. After the uninstall I removed all left over files before reinstalling. Also tried 1.3.0 and have same results. I did notice an event in the app log “The specified RequiredModules entry ‘Universal’ in the module manifest ‘C:\Program Files (x86)\Universal\UniversalDashboard\Frameworks\v3\UniversalDashboard.psd1’ is invalid. Try again after updating this entry with valid values”. Looking at listening ports it looks like it might only be listening on the IPv6 loopback even though IPv6 isn’t enabled. I tried editing the appsettings.json to the IPv4 address and restarted the service but didn’t help. What else should I look for or check?

Hi, I have seen this lately myself, usually, if I go to the dashboard, refresh that, close the browser window that I logged on to the admin console with, and then type in the address again, maybe select one of the other “pages” behind it as well, such as /jobs it comes up again. Strange, but normally I get it to work again, but typical ctrl + F5 would not make it appear. (I use Edge)

Correction on my post. I have “PowerShell Universal” not just the Dashboard. Trying another page doesn’t work for me but I think it’s because I’m unable to enter the creds now.

@bmac I just had this issue but only in Chrome (admin page loaded fine in Opera).

I ended up clearing the Chrome cache and that fixed it

1 Like


Just updated my PowerShell Universal from 1.2.8 to 1.3.0, hosted on WS2019 with IIS. After the upgrade, I get the blank admin screen in Chromium Edge too. The blank screen occures after logging in. Removing the cache (Dev Tools > Application > Clear storage) does not work in my case. But using the incognito mode works fine - so this is our workaround. I have a second setup with the same upgrade path, but there are no issues.

I get those issues in the dev console:
react-dom.production.min.js?2d14:209 ChunkLoadError: Loading chunk 53 failed.
(missing: https://powershell.domain.tld/admin/Routes.bundle.js)
at Function.R.e (https://powershell.domain.tld/admin/index.ab69f5e9a82ee5b5c36d.bundle.js:1:9049)
at Function.I.t.e (https://powershell.domain.tld/admin/index.ab69f5e9a82ee5b5c36d.bundle.js:1:1065)
at eval (webpack-internal:///434:2849:63)
at Ha (webpack-internal:///428:17:349)
at Rj (webpack-internal:///428:263:56)
at Qj (webpack-internal:///428:246:199)
at Kj (webpack-internal:///428:246:128)
at yj (webpack-internal:///428:239:172)
at eval (webpack-internal:///428:123:115)
at exports.unstable_runWithPriority (webpack-internal:///430:19:467)