AutoComplete z index not the same as UDSelect

Product: PowerShell Universal
Version: 4.1.4

Inside a Modal, a UDSelect with loads of data will show all the data in front of the modal, so it can expand way past it.

An auto complete however, doesn’t go infront of the modal and the modal doesn’t expand…

Same data set, see the result below. Notice the modal then gets a scroll bar…

Please note I edited the data for privacy. Where the white box is, there is an array of results.

I can reproduce this. I think the best bet at the moment is just making the modal a little taller to show some of the options.

        Show-UDModal -Content {
                New-UDAutocomplete -Options @(1..1000) 
        } -ContentStyle @{
                minHeight = '500px'

Thank you Adam - this works fine.

Is there any way I can stop the modal from having a scroll bar?

Is there any plans to make AutoComplete work the same as UDSelect in terms of the z index?

I’ve put this on our tracker so we don’t lose it. Z-Index of UDAutocomplete is incorrect. · Issue #2832 · ironmansoftware/issues · GitHub

Upgrading from 2.12.6 to 4.2.11 and having this same issue. I have multiple autocompletes, all on modals, so this is an issue I’d love to see resolved soon.