Nivo Charts Pattern/Fill bug?!

Hi,

lately I am fiddeling around alot with Nivo Charts.
Pattern and Fill are not working in UD 2.7
Can someone confirm that?

I tried the example from the UD docs Website.

$Data = @(
    @{
        country = 'USA'
        burgers = (Get-Random -Minimum 10 -Maximum 100)
        fries = (Get-Random -Minimum 10 -Maximum 100)
        sandwich = (Get-Random -Minimum 10 -Maximum 100)
    }
    @{
        country = 'Germany'
        burgers = (Get-Random -Minimum 10 -Maximum 100)
        fries = (Get-Random -Minimum 10 -Maximum 100)
        sandwich = (Get-Random -Minimum 10 -Maximum 100)
    }
    @{
        country = 'Japan'
        burgers = (Get-Random -Minimum 10 -Maximum 100)
        fries = (Get-Random -Minimum 10 -Maximum 100)
        sandwich = (Get-Random -Minimum 10 -Maximum 100)
    }
)

$Pattern = New-UDNivoPattern -Dots -Id 'dots' -Background "inherit" -Color "#38bcb2" -Size 4 -Padding 1 -Stagger
$Fill = New-UDNivoFill -ElementId "fries" -PatternId 'dots'

New-UDNivoChart -Definitions $Pattern -Fill $Fill -Bar -Data $Data -Height 400 -Width 900 -Keys @('burgers', 'fries', 'sandwich')  -IndexBy 'country'

Hi @AkiraFFM if you have tried this in a previous version and it works, I would certainly file this as a bug here


So that this can be fixed.

Hi @psDevUK,

the bug occured with version 2.6.1, with 2.6.0 it’s working fine.
Could you please have a look on the UseDataColor feature of NivoCharts aswell?
I was not able to get it working.

Best regards.